Opened 10 years ago

Last modified 10 years ago

#126 new enhancement

scons support for qt4 with /usr/lib/qt4 and /usr/include/qt4 paths

Reported by: shaegler Owned by: amz
Priority: minor Milestone: 1.X
Component: Build Version: 1.8
Keywords: Cc:

Description

currently, scons works only for a qt4 installation where the include and libs are under the same /foo/bar/qt4/ path. this is in conflict with the default settings of gentoo linux (perhaps others).

Change History (3)

comment:1 Changed 10 years ago by dirk

  • Milestone changed from 1.8 Release to 1.X

comment:2 Changed 10 years ago by shaegler

this problem also concerns all the other libraries like tif, jpg, cg, ...

reason/background: we have a large customized linux installation (based on debian) here at university which uses one root-filesystem for several plattforms (x86, x86-64, sun4u) and linux/solaris.

most of the packages are built like this:

  • headers:
  • /foo/bar-0.9/include
  • libs (one or more of them):
  • /foo/bar-0.9/i686-debian3.0/lib
  • /foo/bar-0.9/i686-debian3.1/lib
  • /foo/bar-0.9/x86-64-debian3.1/lib

bottomline: like in configure, it would definitely be nice to have separate options for includes and libs...

comment:3 Changed 10 years ago by dirk

  • Owner changed from unassigned to amz
Note: See TracTickets for help on using tickets.